Notifications
Clear all

Calls not passing through from CUbe to CM  

  RSS

Paubert
(@paubert)
New Member
Joined: 6 months ago
Posts: 1
04/12/2019 10:20 am  

Hi Pasha,
I hope you can help me,
we are currently doing a sip migration from ISDN,
I have programmed up new cube,
and accept the calls from the SIP provider.
although im unable to get the call to pass onto the CM 11.5
I’m totally new to this 🙁 but any help is appreciated.
I dare say im missing phone number translations somewhere to direct to the CM,
I have copied the config into this forum.
thanks
regards
Paul

show run
Building configuration…

Current configuration : 3413 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lavvgw002
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$RNqx$fvOhNq/wy1BONvI3pN5GH/
!
no aaa new-model
!
ip domain name xx.com.au
ip name-server 10.3.1.81
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
cts logging verbose
!
!
voice-card 0
!
!
!
voice service voip
ip address trusted list
ipv4 10.0.0.0 255.0.0.0
ipv4 210.193.x.x
ipv4 210.193.x.x
address-hiding
mode border-element
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
modem passthrough nse codec g711alaw
h323
h225 display-ie ccm-compatible
h225 id-passthru
call start slow
sip
bind control source-interface GigabitEthernet0/0.20
bind media source-interface GigabitEthernet0/0.20
header-passing
error-passthru
outbound-proxy ipv4:210.193.x.x
early-offer forced
midcall-signaling passthru
pass-thru content sdp
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729br8
!
!
voice class sip-profiles 1
request CANCEL sip-header Max-Forwards modify “.*” “User-Agent: CUBE”
!
!
license udi pid CISCO2901/K9 sn FGL191422HV
hw-module pvdm 0/0
!
!
!
username pepperxxx privilege 15 secret 5 $1$ptE9$H7kDBpjiokAhzq.OmwaI3/
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 10.3.20.6 255.255.255.0
ip pim dense-mode
h323-gateway voip interface
!
interface GigabitEthernet0/1
ip address dhcp
duplex auto
speed auto
!
ip default-gateway 10.3.20.1
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.3.20.1
!
!
!
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 voip
description *** Outgoing call . outgoing call leg from CUBE to Broadsoft***
destination-pattern .T
session protocol sipv2
session target ipv4:210.193.xx.xx
voice-class codec 1
no vad
!
dial-peer voice 2 voip
description *** CUBE to UC***
huntstop
answer-address 0391015981.
destination-pattern 0391015981.
media forking
session protocol sipv2
session target ipv4:10.3.20.4
incoming called-number 0391015981.
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
!
gateway
timer receive-rtp 1200
!
sip-ua
credentials username 039101xxx password 7 0526352611781C50495541425B5E realm domain.com
retry invite 2
retry response 3
retry register 4
timers expires 300000
registrar dns:domain.com expires 120
host-registrar
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input telnet ssh
!


Quote
Topic Tags
Pasha Teplitsky
(@pasha)
Member Admin
Joined: 4 years ago
Posts: 23
04/12/2019 10:30 am  

Hi Paul,

It would be interesting to see the output of 'debug ccsip messages' for the call.

I have a weird feeling that the call goes back to the ITSP, possibly because of the outbound proxy configuration.
I'm not really sure it's needed.


ReplyQuote
Share: